Fail! Horrible, Horrible Failure!

Haha. Now I'm sure there's at least one guy employed by AMD/ATI that
really doesn't like the title of this post, so let's try to be fair; I'll
lay out the details, and just let everyone be the --FAIL!!!! FAAAAAAIL!--
excuse me, I meant to say 'and let everyone decide for
themselves'. (*cough* fail *cough*...)


Hard lock. Yes, that's right, the same behaviour in Ubuntu 9.10 with
Catalyst 9.12 as I experienced in Slackware and Fedora.

But, this time, we got some entries in the /var/log/Xorg.0.log file:


X.Org X Server 1.6.4
Release Date: 2009-9-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux not-linux 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=f60987d2-4ab7-4257-9abe-715ad2ae6f2e ro quiet splash
Build Date: 14 November 2009 05:48:26PM
xorg-server 2:1.6.4-2ubuntu4.1 (buildd@)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 3 18:13:53 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "aticonfig Layout"
(**) |-->Screen "aticonfig-Screen[0]-0" (0)
(**) | |-->Monitor "aticonfig-Monitor[0]-0"
(**) | |-->Device "aticonfig-Device[0]-0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x3bc0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0:3:0:0) 1002:68b8:1002:2543 ATI Technologies Inc rev 0, Mem @ 0xe0000000/268435456, 0xfdcc0000/131072, I/O @ 0x0000ee00/256, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded by default.
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 7.4.0, module version = 1.0.0
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
compiled for 1.4.99.906, module version = 8.68.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="FireGL - ATI Technologies Inc."
compiled for 7.4.0, module version = 1.0.0
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
compiled for 1.4.99.906, module version = 8.68.2
Module class: X.Org Video Driver
(II) ATI Proprietary Linux Driver Version Identifier:8.68.2
(II) ATI Proprietary Linux Driver Release Identifier: 8.681
(II) ATI Proprietary Linux Driver Build Date: Nov 24 2009 21:15:37
(II) Primary Device is: PCI 03@00:00:0
(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(--) Chipset Supported AMD Graphics Processor (0x68B8) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@3:0:1) found
(II) AMD Video driver is running on a device belonging to a group targeted for this release
(II) AMD Video driver is signed
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) fglrx(0): pEnt->device->identifier=0x9cc3270
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[17] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[18] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[19] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[20] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[21] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[22] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[23] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[24] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[25] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[26] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[27] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[28] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) fglrx(0): === [atiddxPreInit] === begin
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/lib/xorg/modules//libvgahw.so
(II) Module vgahw: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 0.1.0
ABI class: X.Org Video Driver, version 5.0
(II) fglrx(0): PCI bus 3 card 0 func 0
(**) fglrx(0): Depth 24, (--) framebuffer bpp 32
(II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) fglrx(0): Default visual is TrueColor
(**) fglrx(0): Option "DPMS" "true"
(==) fglrx(0): RGB weight 888
(II) fglrx(0): Using 8 bits per RGB (8 bit DAC)
(==) fglrx(0): Gamma Correction for I is 0x06419064
(==) fglrx(0): Gamma Correction for II is 0x06419064
(==) fglrx(0): Buffer Tiling is ON
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Reloading /usr/lib/xorg/modules/linux//libfglrxdrm.so
drmDynamicMajor: found major device number 251
drmDynamicMajor: found major device number 251
drmOpenByBusid: Searching for BusID PCI:3:0:0
drmOpenDevice: node name is /dev/ati/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports PCI:3:0:0
(--) fglrx(0): Chipset: "ATI Radeon HD 5700 Series" (Chipset = 0x68b8)
(--) fglrx(0): (PciSubVendor = 0x1002, PciSubDevice = 0x2543)
(--) fglrx(0): board vendor info: original ATI graphics adapter
(--) fglrx(0): Linear framebuffer (phys) at 0xe0000000
(--) fglrx(0): MMIO registers at 0xfdcc0000
(--) fglrx(0): I/O port at 0x0000ee00
(==) fglrx(0): ROM-BIOS at 0x000c0000
(II) fglrx(0): AC Adapter is used
(II) fglrx(0): Primary V_BIOS segment is: 0xc000
(II) Loading sub module "vbe"
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules//libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
compiled for 1.6.4, module version = 1.1.0
ABI class: X.Org Video Driver, version 5.0
(II) fglrx(0): VESA BIOS detected
(II) fglrx(0): VESA VBE Version 3.0
(II) fglrx(0): VESA VBE Total Mem: 16384 kB
(II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
(II) fglrx(0): VESA VBE OEM Software Rev: 12.12
(II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
(II) fglrx(0): VESA VBE OEM Product: JUNIPER
(II) fglrx(0): VESA VBE OEM Product Rev: 01.00
(II) fglrx(0): ATI Video BIOS revision 9 or later detected
(--) fglrx(0): Video RAM: 1048576 kByte, Type: GDDR5
(II) fglrx(0): PCIE card detected
(--) fglrx(0): Using per-process page tables (PPPT) as GART.
(II) fglrx(0): board/chipset is supported by this driver (original ATI board)
(II) fglrx(0): Using adapter: 3:0.0.



And, here was the xorg.conf file that was used for this test of the
Catalyst 9.12 driver:




Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
Load "dri"
Load "GLcore"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:3:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection




Now, we're going to try Catalyst 10.1 after emptying the Xorg.0.log file
and reruning aticonfig --initial -f.

TO BE CONTINUED....

  • Stumble This
  • Fav This With Technorati
  • Add To Del.icio.us
  • Digg This
  • Add To Facebook
  • Add To Yahoo

No comments:

Post a Comment